2005 Polaris sportmans hot engine warning - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 03-28-2009, 08:35 PM Thread Starter
Junior Member
 
Join Date: Mar 2009
Posts: 1
 
2005 Polaris sportmans hot engine warning

I just acquired a 2005 Polaris sportsman 400 4x4. The hot temp indicator light comes on with the radiator cooling fan as soon as you turn the key to on, whether hot or cold.

I have change the thermister with no success at clearing the "hot "warning...... any thought what could be causing this.

My manual says the Surepower box (ECM) controls this function. Anyway to test???
civbuff60 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-15-2009, 12:51 PM
Junior Member
 
Join Date: Apr 2009
Posts: 1
 
ECM replacement

I'm having the same problem and called my dealer. He said he thought the ECM was deteriorating, however, he asked if it had ever been replaced. There is a warranty replacement for it so I'm taking it in tomorrow. They look it up with the VIN number to see if it has ever been replaced. Check it out, you make get it fixed for free.
chtech is offline  
post #3 of 5 (permalink) Old 09-09-2009, 03:04 PM
Junior Member
 
Join Date: Sep 2009
Posts: 1
 
Quote:
Originally Posted by civbuff60 View Post
I just acquired a 2005 Polaris sportsman 400 4x4. The hot temp indicator light comes on with the radiator cooling fan as soon as you turn the key to on, whether hot or cold.

I have change the thermister with no success at clearing the "hot "warning...... any thought what could be causing this.

My manual says the Surepower box (ECM) controls this function. Anyway to test???
I have a Polaris Sportsman 400 ATV. I changed the oil and filter, greased it and washed it the other day and parked it in the garage. The next day I went out to the garage and the cooling fan was running, but the engine hadn't been started for nearly 24 hours. I turned on the switch and the HOT ENGINE light was flashing even though the engine is cold. I finally had to disconnect the fan just so it would't run my battery down. Suspect moisture in a connection. Any ideas wher to look?
danny_chandler is offline  
post #4 of 5 (permalink) Old 09-10-2009, 02:38 AM
Member
 
polarisman's Avatar
 
Join Date: Jun 2009
Location: epping nh/abbot me
Posts: 48
 
polaris was recalling the ecm's, go to a polaris dealer with vin number and see if your's was done or even part of the recalled atv's.
if it's on the recall list and was never done it will be replaced for free

07 sportsman 800 mine 3000 mile's
08 rzr 800 wife's 2700 mile's
06 sportsman 500 1000 mile's for sale

98 ski doo touring 500 wife's 125 original mile's
98 ski doo formula dlx 583 mine 125 original mile's
polarisman is offline  
post #5 of 5 (permalink) Old 10-04-2009, 10:15 PM
Junior Member
 
Join Date: Oct 2009
Location: Cincinnati
Posts: 6
 
Quote:
Originally Posted by polarisman View Post
polaris was recalling the ecm's, go to a polaris dealer with vin number and see if your's was done or even part of the recalled atv's.
if it's on the recall list and was never done it will be replaced for free
x2. I have two friends with sportsmans that had to have the recalled part replaced. Mine will be taken in shortly to be replaced.
Dirtyone55 is offline  
Sponsored Links
Advertisement
 
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome