arctic atv looses power - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-16-2010, 11:42 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Posts: 3
 
arctic atv looses power

I have a 454 4x4 four wheeler that run's rough after about ten minutes of riding if you apply the rear brake it clears the problem.After twenty minutes of riding it starts to bogg and goes into limp mode.Nothing seemes to solve the problem except parking it.Wondering if it is a carb problem or sensor.If anyone has ideas or more questions that would be great.It will also back fire while running rough.
rumuddy is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 01-04-2011, 09:35 PM Thread Starter
Junior Member
 
Join Date: Nov 2010
Posts: 3
 
Smile Possible fix

I had taken my ATV in several weeks ago to a mechanic.He called me today to say that is either the rectifier or the stator that is causing the problem.I am having him change the rectifier to see if this solves the problem.
rumuddy is offline  
post #3 of 3 (permalink) Old 01-13-2019, 06:23 PM
Junior Member
 
Join Date: Jan 2019
Posts: 6
 
did this fix your problem mine is doing the same thing thanks
MaxJohn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome