Moderators needed - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 01-07-2013, 12:24 PM Thread Starter
Senior Member
 
Toxic's Avatar
 
Join Date: Apr 2011
Posts: 118
 
Moderators needed

In order to try and keep the forum clean of spam and other annoyances a forum requires members willing to work as mods. On a board like this it only makes sense to have a mod with each brand of atv since that is where users can be expected to spend the majority of there time. As such if anybody would be willing to contribute there time please let me know.
Toxic is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-30-2013, 09:41 AM
-LIFETIME MEMBER-
 
Join Date: Mar 2013
Location: Shawano County - WI
Posts: 19
 
If you are still looking for mods, I'm interested. I have a CanAM Outlander, well two of them actually.

Kurt

Roads? Where we are going we don't need roads!

Can am 2013 Outlander Max XT 800R (Red)

~Kurt
Cyngen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome