Please Help Canam Renegade 800 limp mode - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-18-2017, 11:14 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
 
Please Help Canam Renegade 800 limp mode

Hello everyone Im new to atving but i fell in love with it instantly

I just got a 2008 can am renegade 800 everything was going amazing till i drove it the last day of summer i went for a long ride and my rad fan disconnected causing the atv to over heat and throw a limp home mode, from there i fixed the issue but i was always getting a limp home code after. I have checked my p codes and i have none I've checked about 20 times and still no codes

I also cleaned my speed sensor and I checked the transmission wires everything looks good, oil seems good Im lost for words Im very happy with the atv but this one thing is driving me crazy, I took the atv out today and my fan goes on so fans working i also have coolant in my reservoir everything is good but limp mode doesnt want to go away any help is gladly appreciated

also sorry for the spelling writing this while holding my daughter so might have messed up on grammer
Brian Elevated Requena is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome