Bike killing out - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-04-2018, 03:40 PM Thread Starter
Junior Member
 
Join Date: Nov 2018
Posts: 1
 
Bike killing out

I have a 2014 honda foreman fule injected. It takes a while to start first off once it does turn over it runs fine in first and second gear when i shift to 3rd and give it gas it goes to kill like its starving for fule then it kills out. Can this be my fule pump and if so whats a good replacment pump for it seeing as im sure honda is overpriceing there pumps just because this bike it had to be replaced as a whole.
David.h is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-21-2019, 02:02 PM
Junior Member
 
Join Date: Apr 2019
Location: Ohio
Posts: 11
 
Sounds like clogged injectors.
Woodsruner is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome