ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs - Reply to Topic
Thread: Bike killing out Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-21-2019 03:02 PM
Woodsruner Sounds like clogged injectors.
11-04-2018 04:40 PM
David.h
Bike killing out

I have a 2014 honda foreman fule injected. It takes a while to start first off once it does turn over it runs fine in first and second gear when i shift to 3rd and give it gas it goes to kill like its starving for fule then it kills out. Can this be my fule pump and if so whats a good replacment pump for it seeing as im sure honda is overpriceing there pumps just because this bike it had to be replaced as a whole.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome