2018 king quad 750 axi - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-17-2018, 08:47 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 1
 
2018 king quad 750 axi

My break in service is Friday I'm at 350 miles and noticed my coolant level was low why would that be the oil is not milky or anything
Katelyn1B is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-11-2018, 10:28 PM
Junior Member
 
Join Date: Nov 2014
Posts: 5
 
Quote:
Originally Posted by Katelyn1B View Post
My break in service is Friday I'm at 350 miles and noticed my coolant level was low why would that be the oil is not milky or anything
hydrolic
Hard to say, but they topped by coolant off when I took my 500 in for break-in service. Topped off the hydraulic reservoir for the brakes also. Over 500 miles and levels are good.
smitty42 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome