1987 Suzuki 230s ignition - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-27-2019, 07:50 PM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 1
 
1987 Suzuki 230s ignition

I have an 87 Suzuki 230s quad sport. After leaving it alone for a day it will start up 1st kick. After running and driving for about 15 mins is stalls out and will not start back up till the next day. (Extended period of time) i hook a rope to it and try to pull start it. It does fire but won’t run. it has a new coil. Carb is brand new any help would be great thanks.
Thisguy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome