ATV Forum banner

yamaha

  1. General ATV Discussion
    Hello i have a linhai 300 of the 2004+- era. I had a cluch problem so we changed it. After changing it has a hard time to start going. When you pop it into gear and press the gas it barely drives but when it starts going about 20km/h it start driving well the acceleration is normal and...
  2. Yamaha ATVs
    My 2004 Yamaha bear tracker 250 doesn't get spark only randomly it will get spark and start and that normally will only happen in the morning. I replaced the cdi box, thinking that was the reason why it is random when it starts but that still hasn't fixed it. The spark plug is also good i tried...
  3. Yamaha ATVs
    Hey everyone, I’ve been working on getting an old 98 Wolverine 350 back on the trails for a few months now. It’s been in my family for a while but it sat for a few years up until about 2 years ago. When I started fixing it up I put a new intake boot on (between carb and head) and a new carb...
  4. Yamaha ATVs
    Hi All, I have a 1995 Big Bear 350. Last year it started sputtering somewhere above idle. I'd say 1/4 throttle. Doesn't seem to backfire. Just sputter. Enough that you can barely use the machine. Idle is fine though. Went through everything I could think of as well as some other stuff I got...
  5. Yamaha ATVs
    I have a Champ 100 that's in great shape except for the cylinder and head. I'm trying to get it running for the kids. I've been finding it a challenge to find an replacement cylinder and head. Does anyone know if it's possible to put a 80 cylinder and head on a 100? Or does anyone have any...
  6. Yamaha ATVs
    Hi all just picked up a yfm 225 Seems that the vin number was removed at some point I reckon it’s an 86 but just wondering what paint code it is to clean it up I’ve found a vin online that’s the same colour as my 225 JY4-59V00-4GCO30389 Thanks for your help
  7. Yamaha ATVs
    Guys, Im new to yamaha ATV's. my Bruin starts and run's great for about 3 min then dies and wont stay running. it does restart for 5-10 seconds then dies again. Is this a temp issue ? Fan / oil cooler electrical component issue. I have no clue. Any suggestions would be much appreciated.
  8. Yamaha ATVs
    Ever since I have purchased my Warrior, I have not been able to start it without jumping the battery. When I turn the key, no power is received and the neutral light stays off. Pressing the start button does nothing. When I hook it up to jumpstart cables, the neutral light immediately turns on...
Top