ATV Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, this is my first post on here, i think its in the right spot....

Heres my issue, i just rescued an 85 honda ATC 200s from a barn, apparently it has been sitting there for over 10 years not being used....

Cleaned it all up and cleaned the carb got all the little crap done to it.... Had a gas leak out the bottom of the carb overflow, so i cleaned it and checked the float height and all that, and it still leaked so i bought a BRAND NEW carb on eGay and put it on and it still has the same gas leak....

I know i know if its leaking out of the overflow its supposed to be a float/needle and seat issue, but how could that be with both cabs including the brand new one, there has got to be another issue here, and i would love some help, i would really really really appreciate it, i want to get this pig out riding.....

The only other issues i noticed was it stalls out after idling for about 25 seconds unless your riding it almost like its flooding out wich im sure it is cause gas pours out the overflow unless i turn the petcock off...... :thumbsdown::thumbsdown::thumbsdown:

Could this be an issue with the rings? Do they cause gas leaks or am i thinking about this all wrong?




Thanks again in advance!!!! :D
 

·
Banned
Joined
·
377 Posts
Carbage...

welcome to the forum:)
Have you checked/cleaned the Carb. float gas stop valve? Did you check the movement of the stop valve and floats to make sure they operate smoothly? One time I put the float on upside down....I can't remember how I did that...It made the stop valve not contact the float level adjustment. Have you tried adjusting the float level?
 
1 - 4 of 4 Posts
Top