ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
ok dudes here it is, i went riding and rode this damn thing hard too! now i got blue smoke commin out of my exhast. im thinkin its a blown piston ring myself, but u know how alot of your buddies have answers to everything. so im searchin for some advice on what to do from you folks! it runs and idles fine, just blows smoke and its got that sumthin screwed up odor lol. so any advice on what to do, how to fix, or is it even worth it?
 

·
Registered
Joined
·
29 Posts
Smoken

How many hours or miles are on this unit?
Was the unit over heated?
What was the oil level of the unit after the ride?
Look at the air intake system, is the air filter in good condition and all the hoses from the air cleaner in good condition with no leaks to unfiltered air?
Are all the crank case vents clean and open?
What dos the air filter look like?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
it has 700 miles, the filter is clean, the tranny vents clean too! the oil level was about the 1st 1/3rd of the dip stick checkered area.
 

·
Registered
Joined
·
29 Posts
This unit has very low hours on it to be having this type of trouble. If all your crankcase vents are open and clear. Have a look at the vent for the crankcase while the unit is running is there a lot of blow by?
Remove the dip stick when the engine is running and see if you get a lot of smoke from the hole.

Sounds like the engine has been overheated or ran low on oil, as the engine has too low of hours on it ,for normal wear to cause this.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
well the vents r clean, and i just noticed oil commin out of the exhast pipe, so i know that aint gd. my instincts say piston ring. what do u think?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
well hopefully that is just a top end rebuild, im not too keen on motors. i work on jet engines, so not really the same lol
 
1 - 8 of 8 Posts
Top