ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Firstly, hi to everyone, this is my first post around here :)

I've got a 2008 sportsman 500 EFI and it started doing some weird stuff for the past month or so. The dealer took a look at it and said that everything was fine. So that was 100 bucks not well spent!

My problem is that one day i was riding and my popo just died on me. No more power whatsoever. The display turned off and the motor too. Switched it off, told myself I should've stick with computers, switched it back on and the power came back on. It started fine and the rest of the day was great. I thought it was only a glicth. But then a couple of days later, I went to start it up but when i turned the key there was no power. Turned the key, put the power switch to off then on, turned the key.....nothing.....oh wait.....it came alive. Started fine so i went riding and it died on me there too. It did the same thing as earlier, switched off then on wait a couple seconds and then it powers on. I thought it was the battery so i charged it but there is no differance. I'm no mechanic so if anyone as an idea about where i could start looking and as some basic testing that i could perform i'd be more than happy
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I just bought the service manual :)

So i'll check out where and how to check the relay main relay, that is a start. As for the recall the 2008 sportsman 500 EFI is not listed but thanks for pointing it out, i had not think about checking the recalls
 

·
Registered
Joined
·
48 Posts
faulty kill switch
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
You mean the red on/off switch? I'd be damn but come to think of it this could be logical. Is there a way to bypass that switch...i mean an easy way :)
 

·
Registered
Joined
·
48 Posts
yes red on off switch, they are not to much money for a new one or look on ebay.
i have used a zip tie around the bar's and switch just make sure the zip tie is on top of the red kill switch. so zip tie is putting pressure on the red button.
i had a zip tie on for a year once
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
First thanks for all your suggestion. Polarisman...you were right on!! I just had time to check out the source of my problem so idecided to go with the switch first. So i turned on the key and it came alive. Just put my thumb on the switch and it went dead...I did not even move it. Then i hade play with a little to find the right place to the bike would stay on. I dont think that in the year i had this bike that i've done something to that switch to break it. Anyway now i know it's only that so i'm off to ebay to find a replacement :)

thanks again
 

·
Registered
Joined
·
48 Posts
glad i could help you out
 
1 - 8 of 8 Posts
Top