ATV Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a Suzuki King Quad 4X4 300... When it starts and runs fine but when you try to put it in gear it doesn't move. Can anyone help me? Another question, I'm new to ATV riding and figured a utility sport like this would be fun, but does the King Quad 300 need any other kind of fluid besides oil?
 

·
Registered
Joined
·
31 Posts
Brakes holding up??? trans locked up....we need more info Bud....Manual or auto?:dunno:
 

·
Registered
Joined
·
15 Posts
99 king quad,,,need help diagnosis

wont start ,new coil ,new soleniod.first it was hard start,now it wont spark at all.is it stator or cdi box...any clues ,,,if i cant fix it this time its bye bye time.only 1300 miles on it.never beat on .
 

·
Registered
Joined
·
15 Posts
king quad

fixed it ,you wont believe what was wrong.the coil connector was bent back and forth so much it was weakened and wouldnt carry the power to coil.it broke up and ran badly.53 cents for a connector 2 minute fix.i suggest everyone check their wires,not the one 2 the spark plug the one feeding the coil,then check the ground 2.....RUNS PISSA NOW.NO MISS FIRES.....P.S.i put in stator,cdi box ,coil,and switch box before i figured it out.
 

·
Registered
Joined
·
15 Posts
king quad owners

you can upgrade your ignition ,a high performance cdi at rectifier regulator in calif 199 bucks.you can upgrade your stator at electrosport 125 bucks,quik starts more charge power by 20 %...please check your in wire to coil ...best bet change the connector to your coil input ,the stock one is crap.53 cents to change.it makes all the difference in the world.the best mechanic coulndt figure it out but i did the hard way.FOR MORE HORSEPOWER SUPER QUIK STARTS DO MY SUGGESTIONS....NO MATTER WHAT CHANGE THAT CONNECTOR THE STOCK ONE IS NOT HEAVY DUTY TO CARRY THE POWER.:cheeky4:
 
1 - 11 of 11 Posts
Top