ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Engine wont rev, it starts, and boggs down immediately. When I push the winch button it revs up normally until I release the button. Weird?
 

·
Registered
Joined
·
4 Posts
I am currently working on a early 90's 300 that has the same symptoms. If you try to drive it, it starts missing and cutting out. If you turn the headlights on it mostly goes away. It seems like if you get the engine past 1/4 throttle it runs fine. If you are driving and shut the lights off, it completely cuts out the spark and will quit. It starts good and idles good though. At first I though it could be a worn main jet but it appears to be related to power being delivered for spark.
 

·
Registered
Joined
·
6 Posts
I have a similar issue with my Arctic cat idles fine but when you throttle it it wants to die or runs rough with no power for a while when you hit the brake it would get better but now it just runs bad when you try to throttle it. runs ok at first when it gets warn this problem starts
 

·
Registered
Joined
·
4 Posts
After further investigation, the year is 1998. I went through all the connections and cleaned, still didn't help. I bought an aftermarket CDI unit from China for $13.80 and it appears to fix the issue. Haven't been able to take it out for a long ride yet due to weather. It was a cheap fix.
 

·
Registered
Joined
·
6 Posts
I have a similar issue with my Arctic cat idles fine but when you throttle it it wants to die or runs rough with no power for a while when you hit the brake it would get better but now it just runs bad when you try to throttle it. runs ok at first when it gets warn this problem starts
is the CDI also known as the rectifier? I can't find a CDI thanks
 

·
Registered
Joined
·
6 Posts
sorry if I have replied more than once this site is a mess what is the CDI is that also known as the rectifier? thanks
 

·
Registered
Joined
·
4 Posts
No, the CDI is for the ignition, the rectifier converts AC to DC and/or regulates the voltage going to the lights/battery. I searched on Ebay to find mine. Most have a compatibility chart you can scroll through to confirm it will fit your machine. Good Luck.
 

·
Registered
Joined
·
4 Posts
Also check your plug, mine was all black (sooty) since it was not sparking and running rich because of the excess gas. This may help to confirm it was a spark issue. Also make sure your air intake is free. Not enough air will act the same.
 

·
Registered
Joined
·
2 Posts
Engine wont rev, it starts, and boggs down immediately. When I push the winch button it revs up normally until I release the button. Weird?
make sure you check your grounds before you jump to your cdi, it almost sounds like you've got a bad connection and hitting the winch button its letting everything flow back to the battery better. Just a guess though, the bad connection could very well be in the cdi module, it's just a pain in the *** to test unless you have another handy.

Not entirely related, but I stopped to look at a 300 a couple of weeks ago that wasn't charging. The stator was grounding out if I'm not mistaken. Part came in and the owner of the shop had their mechanic replace it, now its charging at the spec 60v/ac but the ignition isn't firing. Checked all the connections, everything is reading the correct ohms. CDI's a little off according to the book but then that seems to be the standard. In any case I had enough time to snatch one off another bike that was supposedly running when it was parked and still no spark. I didn't have time to ohm it, but I'm honestly wondering if something didn't get put quite back right in the motor. Not that he's a bad mechanic but he was fussing about the clearance he had to work with when i got there so idk, any ideas?

Looking the wsm manual back over from home the only other thing I didn't think to do was to leave the cdi plugged in and check the voltages going to and from, but there aren't any specs on what the output should be so I'm going to be just taking a best guess looking at meter there.
 
1 - 10 of 10 Posts
Top