ATV Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
my 2006 polaris sportsman 500 ho efi has an overheating issue that i really need help with !......after driving it for about five minutes the fan comes on, after ten minutes i get the ''hot, check engine'' warning that flashes! all fluids and all the obvious things are good. my local dealership said it was the water temp sensor and after replacing that i still have the same problem...
any suggestions ?
 

·
Banned
Joined
·
377 Posts
2006 Sportsman 500 OverHeating....

Sounds like a faulty fan relay(check wires to fan+feel wires for breaks):thumbsup:
some useful hints.... 1: Overheating is quite common in our tropical climate, but all the cases I have heard about are Polaris. 2: if the fan wiring is disconnected and the fan runs continuously per direct line to battery there is no problem. 3: problem seems to be that even when the display is showing "hot - check engine", or the radiator is actually boiling, the fan is still cutting in and out. Surely it should be running continuously at this point! 4: I have heard that the Electronic Control Module can be changed to suit hot climates.
Maybe, you will need to get it set by the dealer to have the fan turn on sooner and stay on longer.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
i dont think that the fan is the issue, it seems to run the entire time the engine is hot and comes on fairly early.... i wouldnt blame it on the climate either because we have three feet of snow here and im using the bike for plowing....my thoughts are that it is either a faulty empeller or a bad sensor.....?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
alright, thermostat sounds like it will be the next thing i will check....when you say take it out...what exactly do you mean by that ? form what i can tell it is hidden in a rad line that attatches into the block ? correct ? and if so, i just unbolt this rad line from the block and remove the thermostat ? how long will it take till i know that that is the issue?
 

·
Banned
Joined
·
377 Posts
sportsman 500....

Yeah, It looks like the thermostat just sits on the rad....
yes, unbolt the rad and take out the thermostat and mark/note witch way it sits+the way it faces(on a car it has a little loose pin). Then bolt it back on minus the thermostat, fill her up w/ water and
you should be able to tell if it overheats in 5-10 min of it running without the thermostat. If it doesn't overheat/get hot real fast then it's the thermostat because the water is flowing to the radiator and through the engine:thumbsup:

It is just like a thermostat in a car....The thermostat stays closed until the water in the engine reaches a certain temp...you can take them permenantly out in a car. It just makes the heater get hot faster with it in.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
are you sure its in the rad ? because that diagram you sent me earlier shows that the thermostat sits in the side of the block ? when i looked at my bike it looks like it would sit in the side of the block where the rad line enters....?
 

·
Banned
Joined
·
377 Posts
1 - 8 of 8 Posts
Top