Bruin backfiring - ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old Today, 05:10 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 9
 
Bruin backfiring

My 2004 Bruin 350 is backfiring at full throttle. Any other position it runs fine. I have rebuilt carb, changed plug and air filter. Does anyone have any idea what might be causing this?
ghost1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old Today, 05:36 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 9
 
Something I just noticed is when it's in neutral, it will run full throttle with no issues. It only backfires when in gear.
ghost1 is offline  
post #3 of 3 (permalink) Old Today, 06:36 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 9
 
It's not a backfire... It acts like it's getting too much fuel
ghost1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ATV Forum - All Terrain Vehicle discussion for Honda, Yamaha and more ATVs forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome